(杭电 1702)ACboy needs your help again!

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 12357 Accepted Submission(s): 6108

Problem Description

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor 😦.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

解题思路

本题就是模拟队列和栈的原理题(也可以直接用STL库中的队列、栈解决)。栈的特点“先进后出”;队列的特点“先进先出”。所以抓住这两个的特点就能很好的解决这道模拟问题。

代码样例

#include <bits/stdc++.h>
using namespace std;

string s;

void fifo(int n)
{
	int a[1005],i=0,q=0;
	while(n--)
	{
		cin >> s;
		if(s == "IN")
		{
			cin >> a[i];
			i++;
		}
		else
		{
			if(q == i)
				cout << "None" << endl;
			else
			{
				cout << a[q] << endl;
				q++;
			}
		}
	}
}

void filo(int n)
{
	int a[1005],i=0;
	while(n--)
	{
		cin >> s;
		if(s == "IN")
		{
			cin >> a[i];
			i++;
		}
		else
		{
			if(i-1 < 0)
				cout << "None" << endl;
			else
			{
				cout << a[i-1] << endl;
				i--;
			}
		}
	}
}

int main()
{
	int t;
	cin >> t;
	while(t--)
	{
		int n;
		cin >> n;
		cin >> s;
		if(s == "FIFO")
			fifo(n);
		else
			filo(n);
	}
	return 0;
}
posted @ 2019-01-13 18:33  cafu-chino  阅读(156)  评论(0编辑  收藏  举报