The SetStack Computer UVA - 12096
Background from Wikipedia: “Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics, in the sense of a theory invoked to justify assumptions made in mathematics concerning the existence of mathematical objects (such as numbers or functions) and their properties. Formal versions of set theory also have a foundational role to play as specifying a theoretical ideal of mathematical rigor in proofs.”
Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is under construction, and they need you to simulate it in order to verify the operation of the prototype.
The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT, and ADD.
-
PUSH will push the empty set {} on the stack.
-
DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
-
UNION will pop the stack twice and then push the union of the two sets on the stack.
-
INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
-
ADD will pop the stack twice, add the first set to the second one, and then push the resulting set on the stack.
For illustration purposes, assume that the topmost element of the stack is
A = {{},{{}}}
and that the next one is
B = {{},{{{}}}}
For these sets, we have |A| = 2 and |B| = 2. Then:
-
UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.
-
INTERSECT would result in the set {{}}. The output is 1.
-
ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.
Input
An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack computer can execute all the commands in the sequence without ever popping an empty stack.
Output
For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be a line with ‘***’ (three asterisks).
Sample Input
2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT
Sample Output
0
0
1
0
1
1
2
2
2
***
0
0
1
0
0
***
HINT
自己比较菜,C++才刚开始学就上容器之类的有点懵,这几个例题都是抄紫皮书上的,主要是学习里面没讲过的操作吧。下面主要说一下自己感觉不是很好理解的地方吧。
- 空集的表示:set() set加上一个括号就可以表示一个空集了
- 求并集函数: set_union(A.begin,A.end,B.begin,B.end,inserter(x,x.begin()))。前四个分别是两个集合的区间范围,最后两个是一个插入迭代器,元素将被插入到迭代器所表示的元素之前。又得可以接受5个参数得,但目前还是个菜鸡解释不了,查了查资料set就用插入迭代器了,以后学到再补上。
- 求交集函数:set_intersection(A.begin,A.end,B.begin,B.end,inserter(x,x.begin()))。参数和上一个一样。
这个题的思路就是用map分配ID
Accepted
#include<algorithm>
#include <iostream>
#include<sstream>
#include<map>
#include<string>
#include<vector>
#include<set>
#include<stack>
using namespace std;
#define ALL(x) x.begin(),x.end()
#define INS(x) inserter(x,x.begin())
typedef set<int>Set;
map<Set, int>IDcache;
vector<Set>Setcache;
int ID(Set x)
{
if (IDcache.count(x))return IDcache[x];
Setcache.push_back(x);
return IDcache[x] = Setcache.size() - 1;
}
int main()
{
int m, n;
string ss;
cin >> m;
while (m--)
{
cin >> n;
stack<int>s;
while(n--)
{
cin >> ss;
if (ss == "PUSH")s.push(ID(Set()));
else if (ss == "DUP")s.push(s.top());
else {
Set x1 = Setcache[s.top()];s.pop();
Set x2 = Setcache[s.top()];s.pop();
Set x;
if (ss == "UNION")set_union(ALL(x1),ALL(x2),INS(x));
if (ss == "INTERSECT")set_intersection(ALL(x1), ALL(x2), INS(x));
if (ss == "ADD") {
x = x2;
x.insert(ID(x1));
}
s.push(ID(x));
}
cout << Setcache[s.top()].size() << endl;
}
cout << "***" << endl;
}
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 无需6万激活码!GitHub神秘组织3小时极速复刻Manus,手把手教你使用OpenManus搭建本
· C#/.NET/.NET Core优秀项目和框架2025年2月简报
· Manus爆火,是硬核还是营销?
· 终于写完轮子一部分:tcp代理 了,记录一下
· 【杭电多校比赛记录】2025“钉耙编程”中国大学生算法设计春季联赛(1)