加载中...

P5718 【深基4.例2】找最小值

【深基4.例2】找最小值

题目描述

给出 n 和 n 个整数 a_i,求这 n 个整数中最小值是什么。

输入格式

第一行输入一个正整数 n,表示数字个数。

第二行输入 n 个非负整数,表示 a_1,a_2 ... a_n,以空格隔开。

输出格式

输出一个非负整数,表示这 n 个非负整数中的最小值。

样例 #1

样例输入 #1

8
1 9 2 6 0 8 1 7

样例输出 #1

0

提示

数据保证,n<=100 且 0<= a_i <= 1000。

提交答案

#include <bits/stdc++.h>//包含了所有C++头文件的头文件(万能头文件) 
using namespace std;
int main()
{
	int a[10000];//开数组
	int n;
	cin >> n;
	for(int i = 0;i < n;i++)
	    {
	    	cin >> a[i];//数组输入
		}
	int min = a[0];//假设a[0]最小
	for(int i = 0;i < n;i++)//循环排查
	    {
	    	if(a[i] < min)//如果a[i]比假定的min还小
	    	    {
	    	    	min = a[i];//把a[i]赋值为最小值
				}
		}
	cout << min << endl;//输出
	return 0;//好习惯
 } 
/*
8
1 9 2 6 0 8 1 7
0

--------------------------------
Process exited after 24.6 seconds with return value 0
请按任意键继续. . .
*/
posted @ 2023-02-06 15:39  bujidao1128  阅读(579)  评论(0编辑  收藏  举报