加载中...

P5711 【深基3.例3】闰年判断

【深基3.例3】闰年判断

题目描述

输入一个年份,判断这一年是否是闰年,如果是输出 1,否则输出 0。

输入格式

输入一个正整数 n,表示年份。

输出格式

输出一行。如果输入的年份是闰年则输出 1,否则输出 0。

样例 #1

样例输入 #1

1926

样例输出 #1

0

样例 #2

样例输入 #2

1900

样例输出 #2

0

样例 #3

样例输入 #3

2000

样例输出 #3

1

样例 #4

样例输入 #4

1996

样例输出 #4

1

提示

数据保证,$1582 \leq n \leq 2020$ 且年份为自然数。

提交答案

#include<iostream>
using namespace std;

int main()
{
	//指令写在这
	//判断闰年方法:是4的倍数但不是100的倍数,或者是400的倍数。
	int n;
	cin>>n;
	if((n%4==0&&n%100!=0)||n%400==0)
	{
		n=1;
	}
	else
	{
		n=0;
	}
	cout<<n<<endl;
	return 0;
}
/*
1926
0

--------------------------------
Process exited after 10.95 seconds with return value 0
请按任意键继续. . .

1900
0

--------------------------------
Process exited after 2.451 seconds with return value 0
请按任意键继续. . .

2000
1

--------------------------------
Process exited after 3.37 seconds with return value 0
请按任意键继续. . .

1996
1

--------------------------------
Process exited after 2.225 seconds with return value 0
请按任意键继续. . .
*/
posted @ 2023-02-06 15:35  bujidao1128  阅读(156)  评论(0编辑  收藏  举报