hdu 4165 (找规律)

Problem Description
Aunt Lizzie takes half a pill of a certain medicine every day. She starts with a bottle that contains N pills.

On the first day, she removes a random pill, breaks it in two halves, takes one half and puts the other half back into the bottle.

On subsequent days, she removes a random piece (which can be either a whole pill or half a pill) from the bottle. If it is half a pill, she takes it. If it is a whole pill, she takes one half and puts the other half back into the bottle.

In how many ways can she empty the bottle? We represent the sequence of pills removed from the bottle in the course of 2N days as a string, where the i-th character is W if a whole pill was chosen on the i-th day, and H if a half pill was chosen (0 <= i < 2N). How many different valid strings are there that empty the bottle?
 

 

Input
The input will contain data for at most 1000 problem instances. For each problem instance there will be one line of input: a positive integer N <= 30, the number of pills initially in the bottle. End of input will be indicated by 0.
 

 

Output
For each problem instance, the output will be a single number, displayed at the beginning of a new line. It will be the number of different ways the bottle can be emptied.
 

 

Sample Input
6 1 4 2 3 30 0
 

 

Sample Output
132
 1
14
2
5
解析:用s[i][j]表示结果,i, j,分别表示整片的和半片的。则s[i][j] = s[i-1][j+1] + s[i][j-1];因为吃整片的话半片就加一而整片就减一,吃半片了半片就减一。用记忆化搜索时注意初始化。s[0][j] = 1,
 
#include <cstdio>
#include <cstring>

__int64 s[31][31];
__int64 cal(int n, int i)
{
    if (s[n][i] > 0)
    {
        return s[n][i];
    }
    if (n<0 || i<0)
    {
        return 0;
    }
    s[n][i] = cal(n-1, i+1) + cal(n, i-1);
    return s[n][i];
}

int main(void)
{
    int n;

    while (scanf("%d", &n), n)
    {
        memset(s, 0, sizeof(s));
        s[1][0] = 1;
        s[1][1] = 2;
        //s[0][n] = 1;
        for (int i=0; i<31; i++)
        {
            s[0][i] = 1;
        }
        printf("%I64d\n", cal(n, 0));
    }

    return 0;
}

 

3814986502092304

 

posted @ 2013-04-01 18:04  尔滨之夏  阅读(285)  评论(0编辑  收藏  举报