1069. The Black Hole of Numbers (20)

1069. The Black Hole of Numbers (20)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000
#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>

using namespace std;
 int  jian(int n)
{
    int a[4];
    a[0] = n / 1000;
    a[1] = n / 100 % 10;
    a[2] = n / 10 % 10;
    a[3] = n % 10;
    sort(a, a + 4);
    int big, small,temp;
    small = a[0] * 1000 + a[1] * 100 + a[2] * 10 + a[3];
    big=a[3] * 1000 + a[2] * 100 + a[1] * 10 + a[0];
    temp = big - small;
    if (big == temp) printf("%04d - %04d = %04d\n", big, small, temp);
    else
    {
        printf("%04d - %04d = %04d\n", big, small, temp);
    }
        return temp;

}







int main()
{
    int number;
    cin >> number;
    do{
        number = jian(number);
    } while (number != 6174 && number != 0);//0000-0000 = 0 需要输出一次
    

    system("pause");
    return 0;
}

 

posted @ 2017-03-24 14:45  NhdVW0V  阅读(348)  评论(0编辑  收藏  举报