1058. A+B in Hogwarts (20)

1058. A+B in Hogwarts (20)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

注意:直接用PAT-乙的找零钱的代码改的 但是发现有一个测试点通不过 百度过之后发现是范围有可能超出Int

#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
#include <stack>  
using namespace std;


int main()
{
    long g_need, s_need, k_need, g_pay, s_pay, k_pay;
    scanf("%ld.%ld.%ld", &g_need, &s_need, &k_need);
    scanf("%ld.%ld.%ld", &g_pay, &s_pay, &k_pay);
    long k_need_sum = g_need * 17 * 29 + s_need * 29 + k_need;
    long k_pay_sum = g_pay * 17 * 29 + s_pay * 29 + k_pay;
    long k_recv_sum = k_pay_sum + k_need_sum;
    //if (k_pay_sum < k_need_sum) cout << "-";
    long g_recv = k_recv_sum / 29 / 17;
    long s_recv = k_recv_sum / 29 % 17;
    long k_recv = k_recv_sum % 29;
    cout << g_recv << "." << s_recv << "." << k_recv;
    system("pause");
    return 0;
}

 



posted @ 2017-03-24 14:30  NhdVW0V  阅读(206)  评论(0编辑  收藏  举报