[kuangbin带你飞]专题五 并查集 J - A Bug's Life (带权并查集)

J - A Bug's Life

题目链接:https://vjudge.net/contest/66964#problem/J

题目:

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint
Huge input,scanf is recommended.

题意:系(异性关系),然后发现这些条件中是否有悖论

思路:0是同类,1是异类,这里存在两种关系,形成一个环,故更新权值的时候要模2;

//
// Created by hanyu on 2019/7/25.
//
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <set>
using namespace std;
const int maxn=50005;
int father[maxn],value[maxn];
int find(int x)
{
    if(x!=father[x])
    {
        int t=father[x];
        father[x]=find(father[x]);
        value[x]=(value[x]+value[t])%2;
    }
    return father[x];
}
int main()
{
    int T;
    scanf("%d",&T);
    int k=0;
    while(T--)
    {
        int n,m;
        bool flag=false;
        scanf("%d%d",&n,&m);
        for(int i=0;i<=n;i++)
        {
            value[i]=0;
            father[i]=i;
        }
        int x,y;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            int xx=find(x);
            int yy=find(y);
            if(xx==yy)
            {
                if((value[x]-value[y])%2==0)
                    flag=true;
            }
            else
            {
                father[xx]=yy;
                value[xx]=(value[y]-value[x]+1)%2;
            }
        }
        k++;
        printf("Scenario #%d:\n",k);
        if(flag)
            printf("Suspicious bugs found!\n\n");
        else
            printf("No suspicious bugs found!\n\n");
    }
    return 0;
}

 

posted @ 2019-07-26 19:32  branna  阅读(205)  评论(0编辑  收藏  举报