数学概率题

 

Description

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expectednumber of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

 

1

101

 

2

10 3

 

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

题意:给你n个数,

在每一个数你都可以仍骰子,决定下一步走到哪儿,但是你要是扔的数超了这个数组就重新仍,直到到n为止。

用d数组推每一点的概率。

数学期望 = 每一点的概率 * 到该点的值。

#include<iostream>
#include<stack>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
#define N 1000
using namespace std;
#define oo 0x3f3f3f
double d[N];
int a[N];
char str[N];
char s[N];
int main()
{
    int t,n;
    int k = 1;
    scanf("%d",&t);
    while(t--)
    {
        double ans = 0;

        memset(d,0,sizeof(d));
        memset(a,0,sizeof(a));
        d[1] = 1;
        scanf("%d",&n);

        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
            int i,j;

        for(i = 1;i<=n;i++)
        {
            double h;
            if(n - i < 6)
                h = n - i;
            else
                h = 6;
            for(j=1;j<=h;j++)
                d[i+j] += d[i] * (double)(1.0/h);

            ans += (double)a[i] * d[i];
        }
        printf("Case %d: %lf\n",k++,ans);
    }
    return 0;
}

 

posted @ 2016-08-19 10:57  biu~biu~biu~  阅读(259)  评论(0编辑  收藏  举报