问题:Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input:The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output:For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

代码:

(1)DFS

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;

char temp[25][25];
int X[4] = {0,0,1,-1};
int Y[4] = {1,-1,0,0};

void dfs(int sx, int sy);

int n,m;
int sx,sy;
int ans;
int main(){
    while(cin>>m>>n){
        if(n==0&&m==0){
            break;
        }
        ans = 1;
        for(int i=1;i<=n;i++){    
            scanf("%s",temp[i]+1);
            for(int j=1;j<=m;j++){
                if(temp[i][j]=='@'){
                    sx = i;
                    sy = j;
                    break;
                }
            }
        }
        dfs(sx,sy);
        cout<<ans<<endl;
    }
    return 0;
}
void dfs(int sx,int sy){
    if(temp[sx][sy]=='.'){
        ans++;
    }
    temp[sx][sy] = '#';
    for(int i=0;i<4;i++){
        int newX = sx+X[i];
        int newY = sy+Y[i];
        if(newX<1||newX>n||newY<1||newY>m||temp[newX][newY]=='#'){
            continue;
        }
        dfs(newX,newY);
    }
}

(2)BFS

 

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<queue>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;


struct node{
    int x,y;
}Node;

char temp[25][25];
int X[4] = {0,0,1,-1};
int Y[4] = {1,-1,0,0};

void bfs();
bool judge(int x,int y);

int n,m;
int sx,sy,ans;
node S;

int main(){
    while(cin>>m>>n){
        if(n==0&&m==0){
            break;
        }
        for(int i=1;i<=n;i++){    
            scanf("%s",temp[i]+1);
            for(int j=1;j<=m;j++){
                if(temp[i][j]=='@'){
                    S.x = i;
                    S.y = j;
                    break;
                }
            }
        }
        ans = 1;        
        bfs();
        cout<<ans<<endl;
    }
    return 0;
}
void bfs(){
    queue<node> q;
    q.push(S);
    while(!q.empty()){
        node top = q.front();
        q.pop();
        if(temp[top.x][top.y]=='.'){
            ans++;
            temp[top.x][top.y] ='#';
        }
        for(int i=0;i<4;i++){
            int newX = top.x+X[i];
            int newY = top.y+Y[i];
            if(judge(newX,newY)){
                Node.x = newX;
                Node.y = newY;
                q.push(Node);
            }
        }
    }
}

bool judge(int x,int y){
    if(x<1||x>n||y<1||y>m){
        return false;
    }
    if(temp[x][y] == '#'){
        return false;
    }
    return true;
}

 

posted on 2020-02-24 17:01  晨曦生辉耀匕尖  阅读(160)  评论(0编辑  收藏  举报