poj1003 Hangover


Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00
          

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)
import java.util.*;   
public class Main {   
    public static void main(String[] args) {   
        Scanner cin = new Scanner(System.in);   
        String str;   
        int maxCardNum = 0;   
        while(cin.hasNext())   
        {   
            str = cin.nextLine();   
            if(str.equals("0.00"))   
                break;   
            float len = Float.valueOf(str).floatValue();   
            maxCardNum = getCardNum(len);   
            System.out.println(maxCardNum + " card(s)");   
        }   
  
    }   
       
    private static int getCardNum(float len)   
    {   
        float value = 0;   
        int index = 2;     
        while (value < len)   
        {   
            value += 1.0/index;   
            index++;   
        }   
               
        return index-2;   
    }   
  
}  

 

posted @ 2014-08-22 23:49  bigjava  阅读(385)  评论(0编辑  收藏  举报