Lining Up(AtCoder-2271)
Problem Description
There are N people, conveniently numbered 1 through N. They were standing in a row yesterday, but now they are unsure of the order in which they were standing. However, each person remembered the following fact: the absolute difference of the number of the people who were standing to the left of that person, and the number of the people who were standing to the right of that person. According to their reports, the difference above for person i is Ai.
Based on these reports, find the number of the possible orders in which they were standing. Since it can be extremely large, print the answer modulo 109+7. Note that the reports may be incorrect and thus there may be no consistent order. In such a case, print 0.
Constraints
- 1≦N≦105
- 0≦Ai≦N−1
Input
The input is given from Standard Input in the following format:
N
A1 A2 … ANOutput
Print the number of the possible orders in which they were standing, modulo 109+7.
Example
Sample Input 1
5
2 4 4 0 2Sample Output 1
4
There are four possible orders, as follows:2,1,4,5,3
2,5,4,1,3
3,1,4,5,2
3,5,4,1,2Sample Input 2
7
6 4 0 2 4 0 2Sample Output 2
0
Any order would be inconsistent with the reports, thus the answer is 0.Sample Input 3
8
7 5 1 1 7 3 5 3Sample Output 3
16
题意:有 n 个人站一行,对于第 i 个人,给出第 i 个人站在其两端的人数的差值 a[i],问有多少种可能的站法
思路:
对 n 进行奇偶讨论:
- 当 n 为奇数时:中间的人其左右的人的个数一定相同,因此一定为 0 且只有 1 个,从其向两边延伸,每延伸 1 个人,差的人数 +2,因此在奇数情况下,只有 0、2、4、6、8、...其中,除 0 有 1 个外,其余均为 2 个
- 当 n 为偶数时:一定没有两边差为 0 的情况,其两边的差最小为 1,从其两边延伸,每延伸 1 个人,差的人数 +2,因此在偶数的情况下,只有 1、3、5、7...,均为 2 个
根据以上的推导,除了再奇数情况下差为 0 的在中间外,其余的每个位置有两个可选,此时利用乘法原理即可求出结果:
Source Program
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD = 1E9+7;
const int N = 1000000+5;
const int dx[] = {0,0,-1,1,-1,-1,1,1};
const int dy[] = {-1,1,0,0,-1,1,-1,1};
using namespace std;
int a[N];
int bucket[N];
int main() {
int n;
scanf("%d",&n);
for(int i=1; i<=n; i++) {
scanf("%d",&a[i]);
bucket[a[i]]++;
}
bool flag=true;
if(n%2) {
if(bucket[0]!=1)
flag=false;
for(int i=2; i<=n-1; i+=2)
if(bucket[i]!=2)
flag=false;
}
else {
for(int i=1; i<=n-1; i+=2)
if(bucket[i]!=2)
flag=false;
}
LL res=1;
for(int i=0;i<n/2;i++)
res=(res%MOD)*2%MOD;
if(n%2) {
if(!flag)
printf("0\n");
else{
printf("%lld\n",res);
}
}
else {
if(!flag)
printf("0\n");
else{
printf("%lld\n",res);
}
}
return 0;
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 地球OL攻略 —— 某应届生求职总结
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 提示词工程——AI应用必不可少的技术
· .NET周刊【3月第1期 2025-03-02】