m=n^n;两边同取对数,得到,log10(m)=n*log10(n);再得到,m=10^(n*log10(n));
然后,对于10的整数次幂,第一位是1,所以,第一位数取决于n*log10(n)的小数部分
Leftmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13967 Accepted Submission(s): 5339
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
Sample Output
2
2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
Author
Ignatius.L
代码:
#include <stdio.h>
#include <math.h>
int main()
{
double test;
double a;
double c;
__int64 b;
__int64 d;
int n;
scanf("%d",&n);
while(n--)
{
scanf("%lf",&test);
a=test*log10(test);
b=(__int64)a;
c=a-b;
d=(__int64)(pow(10,c));
printf("%I64d\n",d);
}
return 0;
}