hdu1021 数学题 Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42109    Accepted Submission(s): 20133


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
0 1 2 3 4 5
 

Sample Output
no no yes no no no
 

Author
Leojay

还是数学题,用到公式 (a+b)%c=(a%c+b%c)%c;
#include <stdio.h>
typedef long long ll;
const int maxn=999999+1000;
ll f[maxn];
int main()
{
    f[0]=7%3;
    f[1]=11%3;
    for(int i=2;i<maxn-100;i++)
    {
        f[i]=((f[i-1])+f[i-2])%3;
    }
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(f[n]==0)
        printf("yes\n");
    else
        printf("no\n");
    }
    return 0;
}


posted @ 2015-04-13 22:26  编程菌  阅读(113)  评论(0编辑  收藏  举报