hdu 1032 The 3n + 1 problem (打表)

The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26353    Accepted Submission(s): 9784


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1032

Problem Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm:


    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.
 

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no opperation overflows a 32-bit integer.
 

Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
 

Sample Input
1 10 100 200 201 210 900 1000
 

Sample Output
1 10 20 100 200 125 201 210 89 900 1000 174
 

Source
UVA


在我转的hdu题目分类 
 这个题目被分类为简单题,,我仔细看了看,,数据 0 < n < 1,000,000,,, 直接做肯定超时啊,自己试了下果然1秒内算不出来,思前想后没有办法百度了题解,结果题解就是直接暴力做的!! ,,我把自己暴力的代码提交,果然ac,,数据太水了。  但是这题肯定有非暴力的方法:

analys:

暴力的时候观察到,很多数经过题目中算法描述转换的时候,  又回到了之前的数,例如

n=10;
10,, 5, 16, 8, 4, 2, 1;
n=11;
11,, 34, 17, 52, 26, 13, 40, 20, 10, 5, 16, 8 ,4 ,2, 1;
故总数= f【11】=f【10】+8;
所以在打表的时候可以省去很多计算;


打表法:
#include<stdio.h>
#include<algorithm>
using namespace std;
int test[2000010]={};
void init()//打表
{
	for(int i=1;i<=1000000;i++)
	{
		long long  j=i;  //运算中,j可能超过int上限;
		int ans=1;
		while(j!=1)
		{
			if(j<=1000000&&test[j]!=0) //关键, 加上已经记录的位置的统计个数;
			{
				ans+=(test[j]-1);
				break;
			}
			else
			{
				if(j%2==0)
					j/=2;
				else
					j=(j*3+1);
				ans++;
			}
		}
		test[i]=ans;
	}
}
int main()
{
	init();
	 /* for(int i=1;i<=10;i++)
		printf("%d\n",test[i]);  */
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		printf("%d %d ",n,m);
		if(n>m)
			swap(n,m);
		//printf("%d %d ",n,m);
		int maxi=0;
		for(int i=n;i<=m;i++)
		{
			if(test[i]>maxi)
				maxi=max(maxi,test[i]);
		}
		printf("%d\n",maxi);
	}
	return 0;
}

暴力代码:
#include <stdio.h>
#include <algorithm>
using namespace std;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        printf("%d %d ",n,m);
        if(n>m)
            swap(n,m);
        int max=0;
        for(int i=n;i<=m;i++)
        {
            int t=i;
            int cnt=1;
            while(t!=1)
            {
                if(t%2==0)
                    t/=2;
                else
                    t=(t*3+1);
                cnt++;
            }
            if(cnt>max)
                max=cnt;
        }
        printf("%d\n",max);
    }
    return 0;
}


posted @ 2015-04-30 14:11  编程菌  阅读(196)  评论(0编辑  收藏  举报