hdu 1885 Key Task(bfs+状态压缩)

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=1885

Key Task

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1555    Accepted Submission(s): 646


Problem Description
The Czech Technical University is rather old — you already know that it celebrates 300 years of its existence in 2007. Some of the university buildings are old as well. And the navigation in old buildings can sometimes be a little bit tricky, because of strange long corridors that fork and join at absolutely unexpected places.

The result is that some first-graders have often di?culties finding the right way to their classes. Therefore, the Student Union has developed a computer game to help the students to practice their orientation skills. The goal of the game is to find the way out of a labyrinth. Your task is to write a verification software that solves this game.

The labyrinth is a 2-dimensional grid of squares, each square is either free or filled with a wall. Some of the free squares may contain doors or keys. There are four di?erent types of keys and doors: blue, yellow, red, and green. Each key can open only doors of the same color.

You can move between adjacent free squares vertically or horizontally, diagonal movement is not allowed. You may not go across walls and you cannot leave the labyrinth area. If a square contains a door, you may go there only if you have stepped on a square with an appropriate key before.
 

Input
The input consists of several maps. Each map begins with a line containing two integer numbers R and C (1 ≤ R, C ≤ 100) specifying the map size. Then there are R lines each containing C characters. Each character is one of the following:



Note that it is allowed to have
  • more than one exit,
  • no exit at all,
  • more doors and/or keys of the same color, and
  • keys without corresponding doors and vice versa.

    You may assume that the marker of your position (“*”) will appear exactly once in every map.

    There is one blank line after each map. The input is terminated by two zeros in place of the map size.
  •  

    Output
    For each map, print one line containing the sentence “Escape possible in S steps.”, where S is the smallest possible number of step to reach any of the exits. If no exit can be reached, output the string “The poor student is trapped!” instead.

    One step is defined as a movement between two adjacent cells. Grabbing a key or unlocking a door does not count as a step.
     

    Sample Input
    1 10 *........X 1 3 *#X 3 20 #################### #XY.gBr.*.Rb.G.GG.y# #################### 0 0
     

    Sample Output
    Escape possible in 9 steps. The poor student is trapped! Escape possible in 45 steps.

    和hdu1429的胜利大逃亡一样,只是稍微修改下即可;

    三维数组标记的时候可以回头走,因为拿到新的钥匙最后一维的值变了。

    bool vis[110][110][1<<8]; //2^8 //因为多加了一个钥匙的记录,所以可以重复走,只要钥匙不同

    【源代码】

    #include<iostream>
    #include<cstdio>
    #include<queue>
    #include<cstring>
    #define bug printf("bug")
    char map[110][110];
    char key[10]={'b','y','r','g'};
    char door[10]={'B','Y','R','G'};
    bool vis[110][110][1<<8]; //2^8 //因为多加了一个钥匙的记录,所以可以重复走,只要钥匙不同
    int dx[4]={0,0,1,-1};
    int dy[4]={1,-1,0,0};
    int n,m;
    using namespace std;
    struct node{
    	int x,y,step,key;
    }st;
    void bfs(){
    	queue<node>Q;
    	Q.push(st);
    	node now,next;
    	while(!Q.empty()){
    		now=Q.front();
    		//cout<<"now"<<now.x<<" "<<now.y<<" "<<now.step<<" "<<now.key<<endl;
    		Q.pop();
    		if(map[now.x][now.y]=='X'){
    				cout<<"Escape possible in "<<now.step<<" steps."<<endl;
    			return ;
    		}
    		for(int i=0;i<4;i++){
    			next.x=now.x+dx[i];
    			next.y=now.y+dy[i];
    			next.key=now.key;
    			next.step=now.step+1;
    			if(next.x<0||next.x>=n||next.y<0||next.y>=m||map[next.x][next.y]=='#'||vis[next.x][next.y][next.key])
    				continue;
    			if(isupper(map[next.x][next.y])&&map[next.x][next.y]!='X'){
    				for(int j=0;j<4;j++){
    					if(map[next.x][next.y]==door[j]){
    						if(next.key&(1<<j)){
    							vis[next.x][next.y][next.key]++;
    							Q.push(next);
    						}
    					}
    				}
    			}
    			else if(islower(map[next.x][next.y])){
    				for(int j=0;j<4;j++){
    					if(map[next.x][next.y]==key[j]){
    						if((next.key&(1<<j))==0){ //运算符优先级问题,,加括号
    							next.key+=(1<<j);
    						}
    						vis[next.x][next.y][next.key]=1;
    						Q.push(next);
    					}
    				}
    			}
    			else{
    				vis[next.x][next.y][next.key]=1;
    				Q.push(next);
    			}
    		}
    	}
    	cout<<"The poor student is trapped!"<<endl;
    	return ;
    }
    int main(){
    
    	while(cin>>n>>m&&(n||m)){
    		for(int i=0;i<n;i++)
    			for(int j=0;j<m;j++){
    				scanf(" %c",&map[i][j]);
    				if(map[i][j]=='*'){
    					st.x=i;st.y=j;
    					st.step=0;st.key=0;
    				}
    			}
    			memset(vis,0,sizeof(vis));
    		bfs();
    	}
    	return 0;
    }


    posted @ 2015-08-07 09:26  编程菌  阅读(139)  评论(0编辑  收藏  举报