hdu1241 Oil Deposits dfs深搜水题

Oil Deposits
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36869    Accepted Submission(s): 21364




Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 


Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 


Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 


Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
 


Sample Output
0
1
2
2
 


题意比较简单,每个@都是一块油田,相邻的八个方向的油田可以合并,问合并后全图有几块油田


直接遍历,遇到@深搜即可
#include <stdio.h>
#include <stdlib.h>


#define maxn 101




int move[8][2] = {{1,0},{0,1},{-1,0},{0,-1},{1,1},{1,-1},{-1,1},{-1,-1}};//依次从右,上,左,下,右上,右下,左上,左下进行遍历
char a[maxn][maxn];
int n,m;
int juge;
void dfs(int x,int y)
{
    if(x >= 0 && y >= 0 && x < n && y < m)//如果没有超出边界,继续遍历
        if(a[y][x] == '@') {              //满足条件,进行下一步操作
            a[y][x] = '*';                //将满足条件的点标记,防止重复遍历成死循环
            for(int i = 0; i < 8;i++)     //满足条件时,依次对改点的八个方向进行遍历
                dfs(x+move[i][0],y+move[i][1]);
        }
}
int main()
{
    int i,k,q,t;


    while(scanf("%d%d",&m,&n) && (m || n)) {
        juge = 0;
        getchar();
        for(i = 0; i < m; i++) {
            for(k = 0; k < n; k++)
                scanf("%c",&a[i][k]);
            getchar();
        }
        
        for(q = 0; q < m; q++)          //对每个位置遍历
            for(t = 0; t < n; t++)
                if(a[q][t] == '@') {    //如果此处符合条件,juge++
                    dfs(t,q);
                    juge++;
                }


        printf("%d\n",juge);
    }
    return 0;
}



posted @ 2018-02-02 11:55  秃头大师  阅读(133)  评论(0编辑  收藏  举报