1026. 高精度除法

Description

给定两个整数A和B,求A/B。

Input Format

第一行:A

第二行:B

保证A和B的位数少于或等于10000。

Output Format

一行,A/B

Sample Input

10
5

Sample Output

2
import java.util.Scanner;
import java.math.BigInteger;

public class Main{
    public static void main(String args[]){
        Scanner in = new Scanner(System.in);
        BigInteger a,b;
        a = in.nextBigInteger();
        b = in.nextBigInteger();
        System.out.println(a.divide(b));
    }
}

 

posted @ 2017-11-03 15:37  bernieloveslife  阅读(134)  评论(0编辑  收藏  举报