zcmu 1043
1043: 小数Ⅰ
Description
请输出小数点后第n位的数字!
Input
多组测试数据,每组一行,每行一个实数k(保证不是无限循环小数),然后一个空格,再一个整数n.
0<k<10;
0<n;
Output
输出
输出小数点后第n个数字
Sample Input
Sample Output
HINT
k的长度不会超过100个字符
思路:要求输入的数精度比较高,float达不到所要求精度,所以用字符数组。注意考虑以下几种输入情况:00.1234 3 ; 1 6 ; 1.00 5 ;第一种注意小数点位置;第二种注意输入的字符只有一个整数,后面要补0;第三种也是要求打印的小数位置超出了字符的长度,后面需要补0的情况。
代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
#include<time.h>
using namespace std;
#define FORA(i,x,y) for(int i = x; i < y; i++)
#define FORB(i,x,y) for(int i = x; i <= y; i++)
#define FORC(i,y,x) for(int i = y; i > x; i--)
#define maxn 110
#define INF 1000000000
#define LL long long
const int mod = 1000000;
char a[maxn];
int main(){
int n;
memset(a,0,sizeof(a));
while(~scanf("%s %d",a,&n)){
int t = strlen(a);
FORB(i,t,maxn) {
a[i] = '0';
}//如果输入的是整数,后面补0
t = strlen(a);
int tt;
FORB(i,0,t){
if(a[i] == '.') {
tt = i;//记录小数点下标的位置
break;
}
}
int ttt = a[n + tt] - '0';
printf("%d\n",ttt);
}
return 0;
}