zcmu 1040

1040: 二哥的困惑 Ⅲ

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.

Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.

Input

The input consists of several test cases. The first line of each case contains two integers m (2<=m<=20) and n (1<=n<=50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.

Sample Input

2 5
1 7 2 10 9
6 11
62 63 54 66 65 61 57 56 50 53 48 0 0

Sample Output

Case 1: 2
Case 2: 4
 
思路:将牌点数封装为两个数组比较,手中的牌存放在a数组中,没有的牌存放在b数组中。将a,b数组从大到小排序,一 一 进行比较,a大于b,ans++,否则继续比较。
代码如下:
#include<bits/stdc++.h>
using namespace std;
#define maxn 1000 + 10
#define INF 10000000000
#define FORA(i,x,y) for(int i = x; i < y; i++)
#define FORB(i,x,y) for(int i = x;i <= y;i++)
#define FORD(j,y,x) for(int j = y; j >= x; j--)
#define mset(x,v) memset(x,v,sizeof(x))
int a[maxn];
int b[maxn];
int cmp(int x,int y){
    return x>y;
}
int main(){
    int m,n;
    int t = 0;
    bool f[maxn];
    while(~scanf("%d %d",&m,&n)){
        mset(f,false);
        if(m==0&&n==0){
            break;
        }
        FORB(i,1,n){
            scanf("%d",&a[i]);
            f[a[i]] = true;
        }
        sort(a + 1,a + n + 1,cmp);
        int k = 1;
        FORD(i,n*m,1){
            if(!f[i]) b[k++] = i;
        }
        int c = 0;
        int s1 = 1;
        int s2 = 1;
        k--;
        while(s1 <= n){
            if(a[s1] > b[s2]) {
                c++;
            }
            else {
                s2++;
            }
            s1++;
        }
        t++;
        printf("Case %d: %d\n",t,c);
    }
    return 0;
}

posted @ 2018-08-03 08:50  半忧夏  阅读(115)  评论(0编辑  收藏  举报