POJ 2115, C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6358 Accepted: 1384
Description
A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C)
statement;
I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.
Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.
The input is finished by a line containing four zeros.
Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
Sample Input
3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0
Sample Output
0
2
32766
FOREVER
Source
CTU Open 2004
//
#include <iostream>
using namespace std;
__int64 extended_euclid(__int64 a,__int64 b,__int64 &x,__int64 &y){
__int64 ret;
if(b == 0)
{
x = 1;
y = 0;
return a;
}
ret = extended_euclid(b,a%b,x,y);
__int64 t = x;
x = y;
y = t - a / b * y;
return ret;
}
__int64 modular_linear(__int64 a,__int64 b,__int64 n){
__int64 x,y;
__int64 d = extended_euclid(a,n,x,y);
if(b%d) return -1;
__int64 e = x * (b / d) % n + n;
return e % (n / d);
}
int main(int argc, char* argv[])
{
__int64 A,B,C,K;
while(scanf("%lld %lld %lld %lld",&A,&B,&C,&K),A||B||C||K){
__int64 d=modular_linear(C,B-A,(__int64)1<<K);
if(d==-1)
printf("FOREVER\n");
else
printf("%lld\n",d);
}
return 0;
}
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】凌霞软件回馈社区,博客园 & 1Panel & Halo 联合会员上线
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】博客园社区专享云产品让利特惠,阿里云新客6.5折上折
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步