POJ 2503, Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 12536 Accepted: 5529
Description
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay
atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
Hint
Huge input and output,scanf and printf are recommended.
Source
Waterloo local 2001.09.22
//
#include <iostream>
using namespace std;
struct Word
{
Word():next(0){}
char from[12], to[12];
Word* next;
};
inline int calcKey(char word[],int SIZE)
{
int key = 0;
int K = strlen(word);
for(int j=0; j<K; ++j)
key=((key<<2)+(((int)word[j])>>4))^(((int)word[j])<<10);
key = key % SIZE;
key = key < 0 ? key + SIZE : key;
return key;
}
int main(int argc, char* argv[])
{
const int SIZE = 100003;
Word hash[SIZE];
char w[25];
while(gets(w)&& w[0] != 0)
{
Word* pw = new Word;
sscanf(w,"%s %s",pw->to,pw->from);
int key = calcKey(pw->from, SIZE);
Word* pt = &hash[key];
while (pt->next != NULL) pt = pt->next;
pt->next = pw;
}
while(gets(w)&& w[0] != 0)
{
int key = calcKey(w, SIZE);
Word* pt = &hash[key];
bool found = false;
while (pt->next != NULL)
{
pt = pt->next;
if (strcmp(pt->from, w)==0)
{
found = true;
break;
}
}
if(found) printf("%s\n",pt->to);
else printf("eh\n");
}
return 0;
}