POJ 3041, Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4468 Accepted: 2319
Description
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2
Sample Output
2
Hint
INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.
OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
Source
USACO 2005 November Gold
//
#include <iostream>
using namespace std;
bool DFS(int k, bool visited[501], int match[501], bool d[501][501], int N)
{
for (int i = 1; i <= N; ++i)
{
if (visited[i] == false && d[k][i] == true)
{
visited[i] = true;
if (match[i] == -1 || DFS(match[i],visited,match,d, N))
{
match[i] = k;
return true;
}
}
}
return false;
};
int main(int argc, char* argv[])
{
int N, K;
cin >> N >> K;
bool d[501][501];
memset(d, 0, sizeof(d));
int x,y;
for (int i = 0; i < K; ++i)
{
cin >> x >> y;
d[y][x] = true;
}
int match[501];
memset(match, -1, sizeof(match));
bool visited[501];
int cnt = 0;
for (int i = 1; i <= N; ++i)
{
memset(visited, 0, sizeof(visited));
if(DFS(i,visited, match, d, N)) ++ cnt;
}
cout << cnt << endl;
return 0;
}
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】凌霞软件回馈社区,博客园 & 1Panel & Halo 联合会员上线
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步