POJ 1159, Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 26714 Accepted: 8915
Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd
Sample Output
2
Source
IOI 2000
//
#include <iostream>
#include <algorithm>
using namespace std;
int main(int argc, char* argv[])
{
int N;
scanf("%d\n", &N);
char word[5001];
gets(word);
int DP[2][5001];
memset(DP,0,sizeof(DP));
for (int i = 1; i <= N; ++i)
{
DP[i & 1][0] = 0;
for (int j = 1; j <= N; ++j)
{
if (word[i-1]==word[N-j])DP[i & 1][j] = DP[(i-1) & 1][j-1] + 1;
else DP[i & 1][j] = max(DP[(i-1) & 1][j], DP[i & 1][j-1]);
}
}
cout << N - DP[N&1][N] << endl;
return 0;
}