POJ 3259, Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6639 Accepted: 2341
Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
Source
USACO 2006 December Gold
//
#include <iostream>
using namespace std;
int main(int argc, char* argv[])
{
int cases;
cin >> cases;
int paths[5200][3];
int d[501];
int N,M,W;
int S,E,T;
for (int c = 0; c < cases; ++c)
{
fill(&d[0], &d[501], 10000);
cin >> N >> M >> W;
int SIZE = 0;
for (int i = 0; i < M; ++i)
{
cin >> S >> E >> T;
paths[SIZE][0] = S;
paths[SIZE][1] = E;
paths[SIZE][2] = T;
++SIZE;
paths[SIZE][0] = E;
paths[SIZE][1] = S;
paths[SIZE][2] = T;
++SIZE;
}
for (int i = 0; i < W; ++i)
{
cin >> S >> E >> T;
paths[SIZE][0] = S;
paths[SIZE][1] = E;
paths[SIZE][2] = -T;
++SIZE;
}
for (int i = 0; i < N - 1; ++i)
for (int j = 0; j < SIZE; ++j)
d[paths[j][1]] = min(d[paths[j][0]] + paths[j][2],d[paths[j][1]]);
bool avbl = false;
for (int j = 0; j < SIZE; ++j)
if (d[paths[j][1]] > d[paths[j][0]] + paths[j][2])
{
avbl = true;
break;
};
if (avbl) cout << "YES\n";
else cout <<"NO\n";
}
return 0;
}