A strange lift HDU - 1548

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist. 
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"? 

Input  The input consists of several test cases.,Each test case contains two lines. 
  The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn. 
  A single 0 indicate the end of the input.OutputFor each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3
思路:不过是迷宫换成电梯的BFS
AC Code:
复制代码
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
int INF=0x3f3f3f3f;
int N,A,B;
int a[213];
int vis[213];
int bfs(){
    if(A>N||B>N) return -1;
    queue<int> q;
    q.push(A);
    vis[A]=0;
    while(!q.empty() ){
        int p=q.front() ;
        q.pop() ;
        if(p==B) return vis[p];
        int up,down;
        up=p+a[p];
        down=p-a[p];
        if(up<=N&&up>=1&&vis[up]==INF){
            vis[up]=vis[p] +1;
            q.push(up); 
        }
        if(down>=1&&down<=N&&vis[down]==INF){
            vis[down]=vis[p]+1;
            q.push(down); 
        }
    }
    return -1;
}
int main(){
    while(cin>>N>>A>>B&&A){
        for(int i=1;i<=N;i++) cin>>a[i];
        memset(vis,INF,sizeof(vis));
        cout<<bfs()<<endl;
    }
}
复制代码

 

posted @   莫莫君不恋爱  阅读(155)  评论(0编辑  收藏  举报
编辑推荐:
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
阅读排行:
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
· 无需6万激活码!GitHub神秘组织3小时极速复刻Manus,手把手教你使用OpenManus搭建本
· C#/.NET/.NET Core优秀项目和框架2025年2月简报
· DeepSeek在M芯片Mac上本地化部署
· 葡萄城 AI 搜索升级:DeepSeek 加持,客户体验更智能
点击右上角即可分享
微信分享提示
评论
收藏
关注
推荐
深色
回顶
收起