Find a way HDU - 2612

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 

InputThe input contains multiple test cases. 
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character. 
‘Y’ express yifenfei initial position. 
‘M’    express Merceki initial position. 
‘#’ forbid road; 
‘.’ Road. 
‘@’ KCF 
OutputFor each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66

思路:典型的BFS,两次BFS并记录步数。
AC Code:
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<iostream>
#include<utility>
using namespace std;
typedef pair<int,int> P;
int step[4][2]= {1,0,-1,0,0,1,0,-1};
bool vis[210][210];
char map[210][210];
int stepnum[2][210][210];
int n,m,INF=0x3f3f3f3f;
struct node
{
    P p;
    int step;
};
int check(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m&&map[x][y]!='#')
        return 1;
    return 0;
}
void BFS(int a,P p)
{
    memset(vis,false,sizeof(vis));
 
    vis[p.first ][p.second]=true;
    node point,newpoint;
 
    queue<node> q;
   point.p .first=p.first ;
   point.p .second=p.second ;
    point.step=0;
    q.push(point);
 
    while(!q.empty())
    {
        point=q.front();
        q.pop();
        if(map[point.p.first][point.p.second ]=='@')//遇到KFC 记录所走的步数
        {
            stepnum[a][point.p.first ][point.p.second ]=point.step;
        }
        for(int i=0; i<4; i++)
        {
            newpoint.p.first =point.p.first+step[i][0];
            newpoint.p.second =point.p.second +step[i][1];
            if(check(newpoint.p.first,newpoint.p.second)&&!vis[newpoint.p.first][ newpoint.p.second])
            {
                vis[newpoint.p.first][ newpoint.p.second]=true;
                newpoint.step=point.step+1;//每走一格 步数+1
                stepnum[a][newpoint.p.first][newpoint.p.second]=newpoint.step;
                q.push(newpoint);
            }
        }
    }
}
int main (void)
{
    while(~scanf("%d%d",&n,&m))
    {
        P Y,M; 
        getchar();
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j]=='Y')
                    Y=make_pair(i,j);
                else if(map[i][j]=='M')
                    M=make_pair(i,j);
            }
            getchar();
        }
        memset(stepnum,INF,sizeof(stepnum));//一定要放在BFS之前 如果放在BFS里面,第二次BFS时,会把第一次BFS的值覆盖 结果出错
        BFS(0,Y);
        BFS(1,M);
        int step_num=INF;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                if(map[i][j]=='@')//找出同一个KFC中需要走最小的那个点
                    step_num=min(step_num,stepnum[0][i][j]+stepnum[1][i][j]);
        printf("%d\n",step_num*11);
    }
    return 0;
}

 

posted @ 2018-11-03 13:50  莫莫君不恋爱  阅读(158)  评论(0编辑  收藏  举报