POJ 1988 Cube Stacking

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4 

Sample Output

1 0 2

并查集
 N(N<=30,000)堆方块,开始每堆都是一个
方块。方块编号1 – N. 有两种操作:
M x y : 表示把方块x所在的堆,拿起来叠放
y所在的堆上。
C x : 问方块x下面有多少个方块。
操作最多有 P (P<=100,000)次。对每次C
作,输出结果。


解法:
除了parent数组,还要开设
sum数组:记录每堆一共有多少方块。
parent[a] = a, sum[a]表示a所在的堆的
方块数目。
under数组, under[i]表示第i个方块下面有多少
个方块。
under数组在 堆合并和 路径压缩的时候都要更
新。

 1 #include <iostream>
 2 #include <cstring>
 3 #include <cmath>
 4 using namespace std;
 5 
 6 int fa[110000],sum[110000],under[110000];
 7 
 8 int getfather(int a)
 9 {
10     if (fa[a]==a)
11     return a;
12     int t=getfather(fa[a]);
13     under[a]+=under[fa[a]];
14     fa[a]=t;
15     return t;
16 }
17 
18 void merge(int a,int b)
19 {
20     int ta=getfather(a);
21     int tb=getfather(b);
22     if (ta==tb)
23     return;
24     under[ta]=sum[tb];
25     fa[ta]=tb;
26     sum[tb]+=sum[ta];
27 }
28 int main()
29 {
30     int n,a,b;
31     char ch;
32     cin>>n;
33     for (int i=1;i<=n;i++)
34     {
35         under[i]=0;
36         sum[i]=1;
37         fa[i]=i;
38     }
39     while (n--)
40     {
41           cin>>ch;
42           if (ch=='M')
43           {
44                cin>>a>>b;
45                merge(a,b);
46           }
47           else
48           {
49               cin>>a;
50               getfather(a);
51               cout <<under[a]<<endl;
52           }
53     }
54     return 0;
55 }
View Code

posted @ 2015-08-08 17:43  ~Arno  阅读(150)  评论(0编辑  收藏  举报