hdu 1070 Milk

Milk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14739    Accepted Submission(s): 3643


Problem Description
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
 

 

Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
 

 

Sample Input
2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
 

 

Sample Output
Mengniu
Mengniu
 
 
题目不难,但是我做的时候wr了两次,没有注意容量小于200的情况,还有一个就是没注意第6天和超过6天的牛奶都不能喝。
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

struct w
{
       string s;
       int money;
       int v;
       double price;
}k[110];

int cmp(w x, w y)
{
    if (x.price!=y.price)
    return x.price<y.price;
    else
    return x.v>y.v;
}
int main()
{
        int t,n;
        cin>>t;
        while (t--)
        {
              cin>>n;
              for (int i=0;i<n;i++)
              {
                   cin>>k[i].s>>k[i].money>>k[i].v;
                   int day=k[i].v/200;
                   if (day>5)
                   day=5; 
                   if (k[i].v<200)
                   k[i].price=99999;
                   else
                   k[i].price=k[i].money*1.0/day;
              }
              sort(k,k+n,cmp);
              cout <<k[0].s<<endl;
        }
        return 0;
}

 

posted @ 2015-01-22 15:32  ~Arno  阅读(133)  评论(0编辑  收藏  举报