hdu 1088 Write a simple HTML Browser

        HDU 1088 Write a simple HTML Browser

Write a simple HTML Browser

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8560    Accepted Submission(s): 2406


Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
 

 

Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.
 

 

Output
You should display the the resulting text using this rules:
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
  . If you read a <br> in the input, start a new line.
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again).
The last line is ended by a newline character.
 

 

Sample Input
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. <br> Zwei <br> <br> produzieren zwei Newlines. Es gibt auch noch das tag <hr> was einen Trenner darstellt. Zwei <hr> <hr> produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 

 

Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. Zwei produzieren zwei Newlines. Es gibt auch noch das tag -------------------------------------------------------------------------------- was einen Trenner darstellt. Zwei -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 
 
这是一个纯模拟,但对于我这样的渣渣来说能做出来也差不多了,PE了n(n>=5)次,首先用cin.getline PE了,后来发现在处理每行<=80时没算空格,再发现在处理<hr>时没有先换行……,过程有点残酷但结果是美好的。
#include <iostream>
#include <cstring> 
#include <fstream>
using namespace std;

int main()
{
    //ifstream cin("1.txt");//
    char c[1100];
    int l,n=0;
    int t=0;
    while (cin>>c)
    {
          l=strlen(c);
          if (strcmp(c,"<br>")==0)
          {
                cout <<endl;
                n=0;
                t=0;
          }
          else if (strcmp(c,"<hr>")==0)
          {
               if (n!=0)
               cout <<endl;
              for (int i=1;i<=80;i++)
              cout <<"-";
              cout <<endl;
              n=0;
              t=0;
          }
          else if (n+l<80)
          {
               if (t!=0)
               {
               cout <<" ";
               n++;
               }
               t=1;
               cout <<c;
               n+=l;
          }
          else
          {
              cout <<endl;
              n=l;
              t=1;
              cout <<c;
          }
    }
    cout <<endl;
    //system("pause");
    return 0;
}

 

posted @ 2015-01-21 17:07  ~Arno  阅读(288)  评论(0编辑  收藏  举报