ACM学习历程—HDU4956 Poor Hanamichi(模拟)

Poor Hanamichi

Problem Description
Hanamichi is taking part in a programming contest, and he is assigned to solve a special problem as follow: Given a range [l, r] (including l and r), find out how many numbers in this range have the property: the sum of its odd digits is smaller than the sum of its even digits and the difference is 3.
A integer X can be represented in decimal as: \(X = A_n\times10^n + A_{n-1}\times10^{n-1} + \ldots + A_2\times10^2 + A_1\times10^1 + A_0\) The odd dights are \(A_1, A_3, A_5 \ldots\) and \(A_0, A_2, A_4 \ldots\) are even digits.
Hanamichi comes up with a solution, He notices that: \(10^{2k+1}\) mod 11 = -1 (or 10), \(10^{2k}\) mod 11 = 1, So X mod 11 = \((A_n\times10^n + A_{n-1}\times10^{n-1} + \ldots + A_2\times10^2 + A_1\times10^1 + A_0) \mod 11\) = \(A_n\times(-1)^n + A_{n-1}\times(-1)^{n-1} + \ldots + A_2 - A_1 + A_0\) = sum_of_even_digits – sum_of_odd_digits So he claimed that the answer is the number of numbers X in the range which satisfy the function: X mod 11 = 3. He calculate the answer in this way : Answer =  (r + 8) / 11 – (l – 1 + 8) / 11.
Rukaw heard of Hanamichi’s solution from you and he proved there is something wrong with Hanamichi’s solution. So he decided to change the test data so that Hanamichi’s solution can not pass any single test. And he asks you to do that for him.
Input
You are given a integer T (1 ≤ T ≤ 100), which tells how many single tests the final test data has. And for the following T lines, each line contains two integers l and r, which are the original test data. (1 ≤ l ≤ r ≤ \(10^{18}\))
Output
You are only allowed to change the value of r to a integer R which is not greater than the original r (and R ≥ l should be satisfied) and make Hanamichi’s solution fails this test data. If you can do that, output a single number each line, which is the smallest R you find. If not, just output -1 instead.
Sample Input
3
3 4
2 50
7 83
Sample Output
-1
-1
80
 
 
这题只要从m开始,找到第一个不满足的就可以。主要是10的18次方的范围有点吓人,其实真正的搜索范围没有这么大,直接模拟就可以。
 

代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <set>
#include <map>
#include <queue>
#include <string>
#include <vector>
#define INF 0x3fffffff

using namespace std;

int a[20], len;
long long m, n, ad;

void turn(long long m)
{
    len = 0;
    while (m > 0)
    {
        a[len++] = m%10;
        m /= 10;
    }
}

void Add()
{
    a[0]++;
    int i = 0;
    while (a[i] >= 10 && i < len-1)
    {
        a[i+1]++;
        a[i] -= 10;
        ++i;
    }
    if (a[len-1] >= 10)
    {
        a[len-1] -= 10;
        a[len++] = 1;
    }
}

bool Ans()
{
    int p = 1, ans = 0;
    for (int i = 0; i < len; ++i)
    {
        ans += p*a[i];
        p *= -1;
    }
    if (ans == 3) return 1;
    return 0;
}

long long judge()
{
    int k = 0;
    long long l = n - m;
    for (int i = 0; i <= l; ++i)
    {
        k += Ans();
        if (k != ((m+i+8)/11) - ((m+7)/11))
        {
            return m+i;
        }
        Add();
    }
    return -1;
}

int main()
{
    //freopen ("test.txt", "r", stdin);
    int T;
    scanf ("%d", &T);
    for (int times = 0; times < T; ++times)
    {
        scanf ("%I64d%I64d", &m, &n);
        turn(m);
        printf ("%I64d\n", judge());
    }
    return 0;
}

 

posted on 2014-11-16 19:18  AndyQsmart  阅读(165)  评论(0编辑  收藏  举报

导航