【二分图最大独立集】poj 1466 Girls and Boys

Girls and Boys
Time Limit: 5000MS   Memory Limit: 10000K
Total Submissions: 14701   Accepted: 6613

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2


最大独立集=点数-最大匹配
这道题目的cnt要除以2,因为没分二分图的两侧


代码
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int n,ma[505][505],link[505],vis[505];
int dfs(int x)
{
    for(int i=1;i<=n;i++)
    {
        if(!vis[i] && ma[x][i]==1)
        {
            vis[i]=1;
            if(!link[i] || dfs(link[i])==1)
            {
                link[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    freopen("a.in","r",stdin);
    while(scanf("%d",&n)!=EOF)
    {
        memset(ma,0,sizeof(ma));
        memset(link,0,sizeof(link));
        int k,x,y;
        for(int i=1;i<=n;i++)
        {
            scanf("%d: (%d)",&k,&x);
            k++;
            for(int j=1;j<=x;j++)
            {
                scanf("%d",&y);
                y++;
                ma[k][y]=1;
            }    
        }
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i)) cnt++;
        }
        printf("%d\n",n-cnt/2);
    }
    return 0;
}

 


posted @ 2020-11-27 17:46  andyc_03  阅读(68)  评论(0编辑  收藏  举报