【概率dp】hdu 4405 Aeroplane chess

 

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7380    Accepted Submission(s): 4585


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

 

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.
 

 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

 

Sample Output
1.1667 2.3441

 

概率dp模板题,如果有直通的路径,直接转移dp值即可

 

 

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+15;
int n,m,vis[maxn];
double f[maxn];
int main()
{
    freopen("a.in","r",stdin);
    freopen("a.out","w",stdout);
    int x,y;
    while(scanf("%d%d",&n,&m)!=EOF && (n+m))
    {
        memset(vis,-1,sizeof(vis));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            vis[x]=y;
        }
        memset(f,0,sizeof(f));
        for(int i=n-1;i>=0;i--)
        {
            if(vis[i]==-1)
            {
                for(int j=1;j<=6;j++)
                    f[i]+=f[i+j]/6.0;
                f[i]+=1;
            }
            else f[i]=f[vis[i]];
        }
        printf("%.4lf\n",f[0]);
    }
    return 0;
}

 

posted @ 2020-11-26 22:22  andyc_03  阅读(93)  评论(0编辑  收藏  举报