【概率dp】poj 2096 Collecting Bugs

Collecting Bugs
Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 11289   Accepted: 5090
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000


我们按照常规思维考虑: dp[i][j]表示已经找到i种bug,j个系统里找到bug的期望天数。
但是这样推不出来。有可能无穷天也无法满足最终的解,概率很复杂

所以我们需要倒着来设计 
dp[i][j]表示已经找到i种bug,j个系统里找到bug,离目标还需要的期望天数。
初始状态:dp[n][s]=0
出现在某个子系统的概率是1/s,  属于某种类型的概率是1/n。

从dp[i][j]经过一天后可能得到以下四种情况:
dp[i][j]->dp[i+1][j+1];//在一个新的系统里面发现一个新的bug
dp[i][j]->dp[i+1][j];//在原来已发现过bug的系统里发现一个新的bug
dp[i][j]->dp[i][j+1];//在一个新的系统里面发现一个已被发现过的bug
dp[i][j]->dp[i][j];//在已发现过bug的系统发现已发现过的bug
四种到达的概率分别是:
p1=(n-i)*(s-j)/(n*s);
p2=(n-i)*j/(n*s);
p3=i*(s-j)/(n*s);
p4=i*j/(n*s);

还有一个移项的过程也是概率dp的基操

状态转移方程:dp[i][j]=(p1*dp[i+1][j+1]+p2*dp[i+1][j]+p3*dp[i][j+1]+1)/(1-p4)
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int n,s;
const int maxn=1005;
double dp[maxn][maxn];
int main()
{
    freopen("a.in","r",stdin);
    freopen("a.out","w",stdout);
    while(scanf("%d%d",&n,&s)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=n;i>=0;i--)
            for(int j=s;j>=0;j--)
            {
                if(i==n && j==s) continue;
                double p1=(n-i)*(s-j)*1.0;
                double p2=(n-i)*j*1.0;
                double p3=i*(s-j)*1.0;
                double p4=i*j*1.0;
                dp[i][j]=(p1*dp[i+1][j+1]+p2*dp[i+1][j]+p3*dp[i][j+1]+n*s*1.0)/(n*s*1.0-p4);
            }
        printf("%0.4lf\n",dp[0][0]);
    }
    return 0;
 } 

 



代码
posted @ 2020-11-26 21:42  andyc_03  阅读(91)  评论(0编辑  收藏  举报