【数论 欧拉函数】poj 2478 Farey Sequence
Farey Sequence
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 23423 | Accepted: 9425 |
Description
The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input
2 3 4 5 0
Sample Output
1 3 5 9
欧拉函数线性筛法
代码
#include<iostream> #include<cstdio> #include<cstdlib> #include<cstring> using namespace std; const int maxn=1e6+5; typedef long long ll; int tot,prime[maxn],phi[maxn],mark[maxn]; void init() { phi[1]=1; for(int i=2;i<=maxn;i++) { if(!mark[i]) { prime[++tot]=i; phi[i]=i-1; } for(int j=1;j<=tot;j++) { int x=prime[j]; if(x*i>maxn) break; mark[i*x]=1; if(i%x==0) { phi[i*x]=phi[i]*x; break; } else phi[i*x]=phi[i]*phi[x]; } } } int main() { freopen("a.in","r",stdin); freopen("a.out","w",stdout); init(); int n; while(scanf("%d",&n) && n) { ll ans=0; for(int i=2;i<=n;i++) ans+=phi[i]; printf("%lld\n",ans); } return 0; }