[algorithm][poj] POJ 2488 A Knight's Journey
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define MAX_NUM 26
int n, p, q,ok;
int used[MAX_NUM][MAX_NUM];
int pathX[MAX_NUM];
int pathY[MAX_NUM];
int dir[8][2] = { { -2, -1 }, { -2, 1 }, { -1, -2 }, { -1, 2 }, { 1, -2 }, { 1,2 }, { 2, -1 }, { 2, 1 } };
void dfs(int x, int y, int step) {
pathX[step - 1] = x;
pathY[step - 1] = y;
used[x][y] = 1;
if (step == p*q) {ok = 1;return;}
for (int i=0; i<8; ++i) {
int _x = x + dir[i][0];
int _y = y + dir[i][1];
if (_x>=0 && _y>=0 && _x<p && _y<q && !used[_x][_y]) {
dfs(_x, _y, step+1);
}
}
used[x][y] = 0;
}
int main() {
int sum = 0;
cin>>n;
while (n--) {
cin>>p>>q;
ok=0;
memset(used, 0, sizeof(used));
memset(pathX, 0, sizeof(pathX));
memset(pathY, 0, sizeof(pathY));
printf("Scenario #%d:\n", ++sum);
dfs(0, 0, 1);
if (ok != 1) {
printf("impossible\n");
} else {
for (int i = 0; i < p * q; i++) {
printf("%c%d", pathY[i] + 'A', pathX[i] + 1);
}
printf("\n");
}
printf("\n");
}
return 0;
}