【POJ 3616】Milking Time

Milking Time
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6129   Accepted: 2571

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri <ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

 
简单的DP题。
首先要按结束时间排序。
然后我们开始建立状态转移方程。
f[i] 代表在结束时间为 i 的挤奶阶段挤奶的最大值。
那么很明显,方程就是:f[i] = max{f[j] | 0 <= j <= 结束时间对应的开始时间 - R} + 结束时间所对应的奶的数量,如果开始时间-R是小于0,直接取f[0](即0)。
纯DP时间复杂度就是O(NM),N是106,M是1000,会死人的。。。
那么,现在看看DP方程。我们只是要找1~开始时间-R范围内的最大值。那么很简单,线段树优化。
更新就更新i~i这个范围,不用我多说了吧。
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int MAXN = 1000005;
const int MAXM = 1005;

struct Milk
{
    int s, e, p;

    bool operator < (const Milk &b) const
    {
        return (e < b.e) || (e == b.e && s < b.s);
    }

}milk[MAXM];

int maxv[MAXN << 2];
int f[MAXN];
int n, m, r, ans;
int _max, y1, y2;

void query(int o, int L, int R)
{
    if (y1 <= L && R <= y2)
    {
        _max = max(_max, maxv[o]);
        return;
    }
    int mid = (L + R) >> 1;
    int lc = o << 1, rc = lc + 1;
    if (mid >= y1) query(lc, L, mid);
    if (mid + 1 <= y2) query(rc, mid + 1, R);
}

void update(int o, int L, int R, int v, int delx)
{
    if (L == R)
    {
        maxv[o] = max(maxv[o], delx);
        return;
    }
    int mid = (L + R) >> 1;
    int lc = o << 1, rc = lc + 1;
    if (mid >= v) update(lc, L, mid, v, delx);
    if (mid + 1 <= v) update(rc, mid + 1, R, v, delx);
    maxv[o] = max(maxv[lc], maxv[rc]);
}

int main()
{
    scanf("%d%d%d", &n, &m, &r);
    for (int i = 0; i < m; ++i) scanf("%d%d%d", &milk[i].s, &milk[i].e, &milk[i].p);
    sort(milk, milk + m);
    memset(maxv, 0, sizeof(maxv));
    memset(f, 0, sizeof(f));
    for (int i = 0; i < m; ++i)
    {
        _max = 0;
        if (milk[i].s - r > 0) 
        {
            y1 = 1;
            y2 = milk[i].s - r;
            query(1, 1, n - 1);
        }
        f[milk[i].e] = max(f[milk[i].e], _max + milk[i].p);
        update(1, 1, n - 1, milk[i].e, f[milk[i].e]);
    }
    ans = 0;
    for (int i = 1; i < MAXN; ++i) ans = max(ans, f[i]);
    printf("%d\n", ans);
    return 0; 
}

 

 
posted @ 2015-09-03 13:22  albertxwz  阅读(173)  评论(0编辑  收藏  举报