【POJ 3660】Cow Contest

Cow Contest
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8330   Accepted: 4696

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

 
题意:有N只奶牛,它们举行一场竞赛,给出竞赛结果(输入X、Y,表示X赢了Y),利用这些信息,看有多少只奶牛可以确定名次。
做法有点巧妙哟。
X赢了Y,X连一条有向边到Y。
首先枚举每一个点,以这个点开始做正向图的遍历和反向图的遍历,把遍历到的点数加起来,看看是不是遍历完了整幅图都遍历完了。
如果是,那么毫无疑问,这只奶牛是直接或间接地和其它奶牛完成了竞赛。
如果不是,那么说明这只奶牛和某只奶牛还没有分出胜负。
下面给出代码,细节不多。
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN = 105;

bool g[MAXN][MAXN];
int n;
int m;
int ans;
bool v[MAXN];

/* 反向遍历 */
int dfspre(int x)
{
    if (!v[x]) return 0;
    v[x] = false;
    int sum = 1;
    for (int i = 1; i <= n; ++i)
        if (g[i][x]) sum += dfspre(i);
    return sum;
}

/* 正向遍历 */
int dfssuf(int x)
{
    if (!v[x]) return 0;
    v[x] = false;
    int sum = 1;
    for (int i = 1; i <= n; ++i)
        if (g[x][i]) sum += dfssuf(i);
    return sum;
}

int main()
{
    scanf("%d%d", &n, &m);
    memset(g, false, sizeof(g));
    for (int i = 0; i < m; ++i)
    {
        int x;
        int y;
        scanf("%d%d", &x, &y);
        g[x][y] = true;
    }
    ans = 0;
    for (int i = 1; i <= n; ++i) {
            memset(v, true, sizeof(v));
            int prefix = dfspre(i);  /* 储存可遍历点数 */
            memset(v, true, sizeof(v));
            int suffix = dfssuf(i);
            if (prefix + suffix == n + 1) ans++;
    }
    printf("%d\n", ans);
    return 0;
}

 

posted @ 2015-08-20 13:30  albertxwz  阅读(132)  评论(0编辑  收藏  举报