Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the Nhours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43


思路还是很不对,一开始就没有想到可以直接把间隔加在本次结束时间上。其次,我也想的是对每一小时dp,而正确应该是对每一时间段进行dp

 

#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
using namespace std;
struct node{
    int start,end,val;
    bool operator <(const node &a)const{
        return start<a.start;
    }
}nn[1005];
int dp[1005];
int main(){
    int n,m,r;
    cin>>n>>m>>r;
    for(int i=0;i<m;i++){
        cin>>nn[i].start>>nn[i].end>>nn[i].val;
        nn[i].end+=r;
    }
    sort(nn,nn+m);
    for(int i=0;i<m;i++){
        dp[i]=nn[i].val;
        for(int j=0;j<i;j++){
            if(nn[j].end<=nn[i].start){
                dp[i]=max(dp[i],dp[j]+nn[i].val);
            }
        }
    }
    cout << *max_element(dp, dp + m) << endl;
    return 0;
}