浙江大学PAT上机题解析之1002. A+B for Polynomials (25)

1002. A+B for Polynomials (25)

时间限制 
400 ms
内存限制 
32000 kB
代码长度限制 
16000 B
判题程序   
Standard
作者   
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively.  It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000. 

Output

For each test case you should output the sum of A and B in one line, with the same format as the input.  Notice that there must be NO extra space at the end of each line.  Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
 
#include<iostream>
#include <vector>
#include <algorithm>
#include <iomanip>
using namespace std;

bool  compare(pair<int,float> a,pair<int,float> b)
{
	return a.first > b.first ;
}




int main()
{
	int M,N;
	vector<pair<int,float> >  vec;
	vector<pair<int,float> >  vec1;
	vector<pair<int,float> >::iterator it,it1;

	float exp=0;
	float coe=0;

	cin>>M;
	while(M--)
	{
	   cin>>exp>>coe;
	   vec.push_back(make_pair(exp,coe));
	}
	cin>>N;
	while(N--)
	{
		cin>>exp>>coe;
		vec.push_back(make_pair(exp,coe));
	}
		sort(vec.begin(),vec.end(),compare);

	for (it=vec.begin();it!=vec.end();it=it1)
		{ 
			for (it1=it+1;it1!=vec.end() && (*it).first == (*it1).first ;it1++)
             (*it).second += (*it1).second; 
			if ((*it).second !=0)
			{
				vec1.push_back(*it);
			}
			
	   }

	cout<<vec1.size();
	for (it=vec1.begin();it!=vec1.end();it++)
		cout<<" "<<(*it).first<<" "<<fixed<<setprecision(1)<<(*it).second;
  cout<<endl;

 // system("pause");
	return 0;
}

posted on 2013-08-11 22:14  爱你一万年123  阅读(211)  评论(0编辑  收藏  举报

导航