nyoj8-一种排序
一种排序
时间限制:3000 ms | 内存限制:65535 KB
难度:3
- 描述
- 现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);
1.按照编号从小到大排序
2.对于编号相等的长方形,按照长方形的长排序;
3.如果编号和长都相同,按照长方形的宽排序;
4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;
- 输入
- 第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
每一组第一行有一个整数 0<m<1000,表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,
第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000); - 输出
- 顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
- 样例输入
-
1 8 1 1 1 1 1 1 1 1 2 1 2 1 1 2 2 2 1 1 2 1 2 2 2 1
- 样例输出
-
1 1 1 1 2 1 1 2 2 2 1 1 2 2 1
#include <iostream>
#include <algorithm>
using namespace std;
struct val{
int a,b,c;
}d[10000];
int make(val x,val y)
{
if(x.a < y.a)
return 1;
else if(x.a == y.a && x.b < y.b)
return 1;
else if(x.a == y.a && x.b == y.b && x.c < y.c)
return 1;
else
return 0;
}
int main()
{
int test;
cin>>test;
while(test--)
{
int m;
cin>>m;
for(int i = 0;i<m; i++){
cin>>d[i].a>>d[i].b>>d[i].c;
if(d[i].c > d[i].b){
int temp = d[i].c; d[i].c = d[i].b; d[i].b = temp;
}
}
sort(d,d+m,make);
for(int i = 0;i<m;i++)
if(!(d[i].a == d[i-1].a && d[i].b == d[i-1].b && d[i].c == d[i-1].c))
cout<<d[i].a <<" "<<d[i].b<<" "<<d[i].c<<endl;
}
return 0;
}
#include<iostream>
#include<set>
#include<iterator>
using namespace std;
struct Rect
{
int num,length,width;
};
bool operator<(const Rect& r1,const Rect& r2)
{
return r1.num<r2.num || r1.num==r2.num && r1.length<r2.length ||r1.num==r2.num&&r1.length==r2.length &&r1.width<r2.width;
}
istream& operator>>(istream& in,Rect& r)
{
in>>r.num;
int a,b;
cin>>a>>b;
r.length=max(a,b);
r.width=min(a,b);
return in;
}
ostream& operator<<(ostream& out,const Rect& r)
{
return out<<r.num<<" "<<r.length<<" "<<r.width;
}
int main()
{
int num;
cin>>num;
while(num--)
{
set<Rect> rs;
Rect r;
int n;
cin>>n;
while(n--)
{
cin>>r;
rs.insert(r);
}
copy(rs.begin(),rs.end(),ostream_iterator<Rect>(cout,"\n"));
}
}