HDU1867 - A + B for you again

Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.

Input

For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.

Output

Print the ultimate string by the book.

Sample Input

asdf sdfg
asdf ghjk

Sample Output

asdfg
asdfghjk
#include <stdio.h>
#include <string.h>

int next[100005];

void getnext(char str[])
{
    int i = 1,j = 0;
    int len = strlen(str);
    next [0] = -1;
    while(i < len)
    {
        if(j == -1 || str[i] == str[j])
        {
            i++;
            j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}

int kmp(char str1[],char str2[])
{
    int i= 0,j = 0;
    int len1 = strlen(str1),len2 = strlen(str2);
    getnext(str2);
    while(i<len1 && j<len2)
    {
        if(j == -1 || str1[i] == str2[j])
        {
            i++;
            j++;
        }
        else
            j = next[j];
    }
    if(i == len1)
        return j;
    return 0;
}

int main()
{
    int x,y;
    char str1[100005],str2[100005];
    while(scanf("%s%s",str1,str2)!=EOF)
    {
        x = kmp(str1,str2);
        y = kmp(str2,str1);
        if(x == y)
        {
            if(strcmp(str1,str2)>0)
            {
                printf("%s",str2);
                printf("%s\n",str1+x);
            }
            else
            {
                printf("%s",str1);
                printf("%s\n",str2+x);
            }
        }
        else if(x>y)
        {
            printf("%s",str1);
            printf("%s\n",str2+x);
        }
        else
        {
            printf("%s",str2);
            printf("%s\n",str1+y);
        }
    }

    return 0;
}

 

posted @   浮生惘语  阅读(146)  评论(0编辑  收藏  举报
编辑推荐:
· 智能桌面机器人:用.NET IoT库控制舵机并多方法播放表情
· Linux glibc自带哈希表的用例及性能测试
· 深入理解 Mybatis 分库分表执行原理
· 如何打造一个高并发系统?
· .NET Core GC压缩(compact_phase)底层原理浅谈
阅读排行:
· 手把手教你在本地部署DeepSeek R1,搭建web-ui ,建议收藏!
· 新年开篇:在本地部署DeepSeek大模型实现联网增强的AI应用
· Janus Pro:DeepSeek 开源革新,多模态 AI 的未来
· 互联网不景气了那就玩玩嵌入式吧,用纯.NET开发并制作一个智能桌面机器人(三):用.NET IoT库
· 【非技术】说说2024年我都干了些啥
点击右上角即可分享
微信分享提示