UVAOJ 408 基础题 均匀的生成器 数论

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=349
 Uniform Generator 

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

 

displaymath29

 

where `` tex2html_wrap_inline31 " is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

 

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

 

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

 

Input

Each line of input will contain a pair of integers for STEP and MOD in that order ( tex2html_wrap_inline77 ).

 

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either ``Good Choice" or ``Bad Choice" left-justified starting in column 25. The ``Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message ``Bad Choice". After each output test set, your program should print exactly one blank line.

 

Sample Input

 

3 5
15 20
63923 99999

 

Sample Output

 

         3         5    Good Choice

        15        20    Bad Choice

     63923     99999    Good Choice

 

/*************************************************************************
    > File Name: 12345.cpp
    > Author: acmicpcstar
    > Mail: acmicpcstar@gmail.com
    > Created Time: 2014年04月24日 星期四 11时46分18秒
 ************************************************************************/

#include<iostream>
#include<string>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const double pi=atan(1.0)*4.0;
int gcd(int a,int b)
{
    return a%b?gcd(b,a%b):b;
}
int main()

{
   // freopen("in","r",stdin);
//freopen("out","w",stdout);
int a,b;int mark=1;
while(cin>>a>>b)
{
    /*if(mark==1)
{
    mark=0;
}
else cout<<endl;*/
    if(gcd(a,b)==1) printf("%10d%10d    Good Choice\n\n",a,b);
else printf("%10d%10d    Bad Choice\n\n",a,b);}
return 0;
}

 

只要取公约数=1就可以了。。。无奈少了个空格。。。然后//。。。最后少个回车居然wa了。。。

改回来居然对了~~~老题不严格啊啊~

posted @ 2014-04-24 22:08  acmicpcstar  阅读(283)  评论(0编辑  收藏  举报