经典DP问题--poj1088滑雪

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
 1  2  3  4 5

16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

题解:找到最长的一条路径首先想到的是搜索DFS,这题要用到DP和记忆化搜索

#include<iostream>
using namespace std;
int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
int map[102][102];
int dp[102][102];
int R,C;
int DFS(int x,int y)
{
    int tx;int ty;
    if(dp[x][y])
    return dp[x][y];
    for(int i=0;i<4;i++)
    {
        tx=x+dir[i][0];
        ty=y+dir[i][1];
        if(tx>=0&&ty>=0&&tx<R&&ty<C&&map[tx][ty]<map[x][y])
        {
            int temp=DFS(tx,ty);
            if(temp>=dp[x][y])
            {
                dp[x][y]=temp+1;
            }
        }
    }
    return dp[x][y];
}
int main()
{
    int i,j,t;
    while(cin>>R>>C)
    {
        for(i=0;i<R;i++)
            for(j=0;j<C;j++)
            {
                cin>>map[i][j];
                dp[i][j]=0;
            }
        int max=-1;
        for(i=0;i<R;i++)
            for(j=0;j<C;j++)
            {
                t=DFS(i,j);
                if(max<t)
                max=t;
            }
        cout<<max+1<<endl;
    }
}

 

 
posted @ 2018-08-28 15:15  Hacklover  阅读(346)  评论(0编辑  收藏  举报