欧拉常数(调和级数求和) Harmonic Number

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

这里写图片描述
这里写图片描述
In this problem, you are given n, you have to find Hn.
Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

公式。。。记住就行
欧拉常数y=0.57721566490153286060651209
ans=log(n)+y+1.0/(2*n)

#include <iostream>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stdio.h>
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int maxn=1e4;
double f[maxn+5];
int main()
{
    int T;
    cin>>T;
    f[1]=1;
    for(int i=2;i<=maxn;i++)
        f[i]=f[i-1]+1.0/i;
    for(int cas=1;cas<=T;cas++)
    {
        int n;
        cin>>n;
        if(n<=maxn)
        printf("Case %d: %.10lf\n",cas,f[n]);
        else
        {
            double ans=log(n)+0.57721566490153286060651209+1.0/(2*n);
            printf("Case %d: %.10lf\n",cas,ans);
        }
    }
    return 0;
}
posted @ 2017-08-21 21:31  ACagain  阅读(1257)  评论(0编辑  收藏  举报