Parencodings http://acm.pku.edu.cn/JudgeOnline/problem?id=1068

Time Limit: 1000MS
Memory Limit: 10000K

Total Submissions: 8287
Accepted: 4920

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:


S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
-------------------------------------------------------

Solution

This one is fairly simple, the key is to find the inner connection between this p-sequence and w-sequence. Only need one pass to finish the conversion.

import java.util.Scanner;

public class POJ_1068 {

	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int test_num = in.nextInt();
		for (int k = 0; k < test_num; k++) {
			String result = "";
			int element_num = in.nextInt();
			int leftCounter[] = new int[element_num];
			int current = -1, prev = -1;
			for (int i = 0; i < element_num; i++) {
				if (prev == -1) {
					current = in.nextInt();
					prev = current;
					leftCounter[i] = current;
				} else {
					prev = current;
					current = in.nextInt();
					leftCounter[i] = current - prev;
				}
			}
			for (int i = 0; i < element_num; i++) {
				if (leftCounter[i] != 0) {
					result += "1 ";
					leftCounter[i]--;
				} else {
					for (int j = i - 1; j != -1; j--) {
						if (leftCounter[j] != 0) {
							result += (1 + i - j) + " ";
							leftCounter[j]--;
							break;
						}
					}
				}
			}
			System.out.println(result);
		}
	}

}
posted on 2010-01-14 14:21  流光星烁  阅读(412)  评论(0编辑  收藏  举报