1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

 

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
//求A+B两个多项式的和,指数相同的系数相加逆序输出
#include<iostream>
#include<iomanip>
using namespace std;
int main(void)
{
int k1,k2,a,b,i,num=0;
double n1[1001],n2[1001],sum[1001];
for(i=0; i<1001; i++)
{
n1[i]=0;
n2[i]=0;
sum[i]=0;
}
cin>>k1;
for(i=0; i<k1; i++)
{
cin>>a;
cin>>n1[a];
}
cin>>k2;
for(i=0; i<k2; i++)
{
cin>>b;
cin>>n2[b];
}
for(i=0; i<1001; i++)
{
sum[i]=n1[i]+n2[i];
if(sum[i]!=0)
num++;
}
cout<<num;
for(i=1000; i>=0; i--)
{
if(sum[i]!=0)
{
//设定精度和输出格式
cout<<" "<<i<<" "<<fixed<<setprecision(1)<<sum[i];
// num--;
// if(num>0)
// cout<<" ";
}
}
return 0;
}


posted @ 2012-02-17 11:49  丶Blank  阅读(241)  评论(0编辑  收藏  举报