【Java[方法调用]】7-3 计算函数P(n,x)
输入一个正整数repeat (0<repeat<10),做repeat次下列运算:
输入一个整数n (n>=0)和一个双精度浮点数x,输出函数p(n,x)的值(保留2位小数)。
1 (n=0)
x (n=1)
((2n-1)p(n-1,x)-(n-1)*p(n-2,x))/n (n>1)
例:括号内是说明
输入样例:
3 (repeat=3)
0 0.9 (n=0,x=0.9)
1 -9.8 (n=1,x=-9.8)
10 1.7 (n=10,x=1.7)
输出样例:
p(0,0.90)=1.00
p(1,-9.80)=-9.80
p(10,1.70)=3.05
import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner sc=new Scanner(System.in);
int r=sc.nextInt();
for(int i=0;i<r;i++)
{
int n=sc.nextInt();
double x=sc.nextDouble();
double t=p(n,x);
System.out.printf("p(%d,%.2f)=%.2f\n",n,x,t);
}
}
public static double p(int n,double x)
{
double t;
if(n==0)
t=1;
else if(n==1)
t=x;
else
t=((2*n-1)*p(n-1,x)-(n-1)*p(n-2,x))/n;
return t;
}
}