(数论) SGU 105

D - Div 3
Time Limit:250MS     Memory Limit:4096KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

 

There is sequence 1, 12, 123, 1234, ..., 12345678910, ... . Given first N elements of that sequence. You must determine amount of numbers in it that are divisible by 3.

 

Input

Input contains N (1<=N<=231 - 1).

 

Output

Write answer to the output.

 

Sample Input

4

Sample Output

2
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
      int n;
      while(scanf("%d",&n)!=EOF)
      {
            int ans=(n/3)*2+((n%3)==2?1:0);
            printf("%d\n",ans);
      }
      return 0;
}

  

posted @ 2015-01-20 13:03  心田定则  阅读(104)  评论(0编辑  收藏  举报