hdu 1525

Euclid's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2193    Accepted Submission(s): 981


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

25 7
11 7
4 7
4 3
1 3
1 0 

an Stan wins. 

 

 

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 

 

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

 

 

Sample Input
34 12 15 24 0 0
 

 

Sample Output
Stan wins Ollie wins
 

 

Source
 
a>b 
 
其中 先手必胜状态,有 b==0 ,a/b>=2,a%b==0
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
using namespace std;
int a,b;
int main()
{
      while(scanf("%d%d",&a,&b)!=EOF)
      {
            if(a==0&&b==0)
                  break;
            if(a<b) swap(a,b);
            bool flag=true;
            while(1)
            {
                  if(b==0||a%b==0||a/b>=2)
                        break;
                  int t=b;
                  b=a-b;
                  a=t;
                  flag=!flag;
            }
            if(flag)
            {
                  printf("Stan wins\n");
            }
            else
                  printf("Ollie wins\n");
      }
      return 0;
}

  

posted @ 2015-01-16 22:17  心田定则  阅读(119)  评论(0编辑  收藏  举报